openssl @1.0.1b_0 breaks Ruby in macports

Posted by face on May 02, 2012


When updating to the latest macports, openssl 1.0.1 is installed. Then whenever Ruby tries to connect to facebook, you get errors like:

Errno::ECONNRESET (Connection reset by peer – SSL_connect)

The solution…downgrade openssl. You can see what you versions you have installed:

port installed | grep  openssl
  openssl @1.0.0h_0
  openssl @1.0.1_2
  openssl @1.0.1b_0 (active)

Ok Great, we have the old version:

sudo port activate openssl @1.0.0h_0

Oh, but what if you don’t have the correct version already installed? Thats a little trickier:

svn co -r  90715
cd openssl
sudo port install

Update: Installing Openssl 1.0.1c and rebuilding ruby also fixes the problem

sudo port selfupdate
sudo port update outdated
sudo port uninstall ruby19
sudo port install ruby19 +doc+nosuffix

And now I have ruby 1.9 and openssl 1.0.1c talking to facebook without peer resets.


A hui hou!

Digg! Delicious! Technorati Blinklist Furl Reddit

Leave a response


Hint: Comments now accept textile.